📚 开源资源分享——颜佐光的个人书架
✉️ 联系站长
书架 / docker / 安装

Docker容器开机自动启动

2019-11-21 12:10 · 约 1,027 字 · 浏览 2,825 次 · 更新 2020-05-16 11:10安装

容器自启动

sudo systemctl enable docker
sudo systemctl start docker

服务自启动

部署项目服务器时,为了应对停电等情况影响正常web项目的访问,会把Docker容器设置为开机自动启动。

在使用docker run启动容器时,使用--restart参数来设置:

# docker run -m 512m --memory-swap 1G -it -p 58080:8080 --restart=always 
--name bvrfis --volumes-from logdata mytomcat:4.0 /root/run.sh

--restart具体参数值详细信息:
* no - 容器退出时,不重启容器,默认值为no;
* on-failure - 只有在非0状态退出时才从新启动容器;容器发生error而退出(容器退出状态不为0)重启容器,可以指定重启的最大次数,如:on-failure:10
* unless-stopped 在容器已经stop掉或Docker stoped/restarted的时候才重启容器
* always - 无论退出状态是如何,都重启容器;在容器已经stop掉或Docker stoped/restarted的时候才重启容器,手动stop的不算。

注意:

  • 容器只有在成功启动后restart policy才能生效。这里的"成功启动"是指容器处于up至少10秒且已经处于docker监管。这是避免没有成功启动的容器陷入restart的死循环。

  • 如果手动stop一个容器,容器设置的restart policy将会被忽略,除非Docker守护进程重启或者容器手动重启;这是避免了如果重启策略设置了always,如果不忽略policy那么容器无法手动停止。

还可以在使用on - failure策略时,指定Docker将尝试重新启动容器的最大次数。默认情况下,Docker将尝试永远重新启动容器。

# sudo docker run --restart=on-failure:10 redis

如果创建时未指定 --restart=always ,可通过update 命令

docker update --restart=always xxx
← 返回《docker》目录书架 →